InfoPath Operation could not be completed

When trying to move an InfoPath from Prod to Test, I ran into a small problem.

Once I got to the point of needing to update my data connections, I received this error:

Operation could not be completed

The amount of detail is overwhelming!

The url for my test site was http://sharepoint:1200/sites/blah

After creating a new web app and having the network guys create a new DNS entry, the error went away.

The new url is

Updated my data connections, no more error!


5 thoughts on “InfoPath Operation could not be completed

  1. This is not the real fix.
    You need to have a top-site on your webApp if you want InfoPath 2010 and Sharepoint 2010 communicate.

    •On Site Collections, click on the Create site collections link.
    •Then from the drop down list, Select the web application where you wanted to create the site collection.
    •Give the title and the description then select “/” from the URL drop down list.
    •Then choose a template for your site and enter the primary site collection Administrator and OK.

  2. Thanks to Rach for his additional comments. Sure enough Infopath cannot connect unless the site collection is at the top-level. Any other address will be returned as invalid.

  3. I have created a root site collection using the team site template and I am still receiving the error. Am I missing something? Please assist.

  4. Rach is correct. Creating a default Site Collection by his third bullet step does the trick. Thanks Rach!

Leave a Reply

Your email address will not be published. Required fields are marked *