the language of this installation package is not supported by your system

When trying to install SharePoint Designer 2010 on my PC, I ran into an error saying Designer 2007 was installed on the box.

The problem was, I had SharePoint Designer 2007 installed, and it’s a 32-bit install. When I tried to uninstalled Designer 2007 I was getting this error:

The language of this installation package is not supported by your system

No matter what google-related-fix I tried, I couldn’t uninstall it.

What I did to fix things:
Installed Office 2007
Installed Designer 2007

Uninstalled Desinger 2007
Uninstalled Office 2007

Then I was able to install SharePoint Designer 2010.

1 thought on “the language of this installation package is not supported by your system

Leave a Reply

Your email address will not be published. Required fields are marked *